2011/02/04

Eclipse に既存の Android プロジェクトをインポートする際、はまるポイント3

Eclipse に既存の Android プロジェクトをインポートする際、はまるポイント1
Eclipse に既存の Android プロジェクトをインポートする際、はまるポイント2
に続いて、もう一点はまったのでご報告します。

インポートした際、@override などのアノテーションでひっかかる場合は、以下の方法で治るかもしれません。

2011/10/11 追記
最近、Javaのアップデートが激しいので、以下のようなエラーが出ました。
Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.
これ、指示されたように Fix Project Properties を選択してもうまくいかない場合があります。
というのも、Fix Project Properties は以下のコンパイラ選択を自動でやり直してくれるツール(?)なのですが、何故か1.5にしちゃうんです。
もとが1.6で作成されているプロジェクトの場合、Fix Project Properties では直りません。以下の手順を手動で実行して1.6にしてあげましょう。


プロジェクト右クリック → プロパティー → Java コンパイラー

プロジェクト固有の設定を可能にするにチェックを入れて、コンパイラ準拠レベルを変更します。
ちょっと前までは、1.5 でないとコンパイルできなかったのですが、最近になって 1.6 でもコンパイルが通るようになったみたいです。(あんまり調べてませんが…)
どちらか、プロジェクトで採用しているコンパイラを選ばないとうまくいきません。


また、デフォルトのコンパイラから変更してしまうことも出来ます。

ウィンドウ → 設定 → Java → コンパイラ

この方法で変更すると、同じワークスペースのプロジェクト全部に影響するので気をつけてください。


10 件のコメント:

通りすがり さんのコメント...

助かりました~!
ありがとうございました。

匿名 さんのコメント...

おかげで解決しました。

匿名 さんのコメント...

とても助かりました!有難うございます

ゆうすけ さんのコメント...

みなさんのお役に立てているようで良かったです。

匿名 さんのコメント...

この方法にすると R.java っというファイルにエラーがでてしまいます・・・

ゆうすけ さんのコメント...

おっと。
どのようなエラーが出ているかわからないので、お役に立つかわかりませんが、 Project -> Clean をすると直ったりしませんでしょうか?

匿名 さんのコメント...

説明が分かりやすくて助かります。
でも、javaのコンパイラの準拠レベルを変えてもエラーが出たままでした・・・。

ゆうすけ さんのコメント...

どのようなエラーが出ているのかによるのですが、もし

Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.

が出ているのだとすると、コンパイラの準拠レベルは1.7のまま変更できていないということです。
デフォルトコンパイラよりプロジェクト固有のコンパイラが優先されるので、プロジェクト固有のコンパイラが設定されていると変更が反映されないように見えているのではないかと推測しますが、いかがでしょうか?

匿名 さんのコメント...

ありがとうございます。
直りました。
JRE6がインストール出来ていなかったようでした。

現在、AndARを使って、ARアプリを開発しているのですが、オリジナルの3Dモデルが表示できず
なかなか苦労しています><

ゆうすけ さんのコメント...

解決したようで何よりです。

ARですかー。
最初に動くようにするまでが大変そうですね。
でも、動いたら楽しそうです。
頑張ってください。